Re: cip-dev Digest, Vol 17, Issue 22

Binh Thanh. Nguyen <binh.nguyen.uw@...>

Hello Daniel,

-----Original Message-----
From: cip-dev-bounces@... [mailto:cip-dev-
bounces@...] On Behalf Of cip-dev-request@...
Sent: Tuesday, October 24, 2017 2:00 PM
To: cip-dev@...
Subject: cip-dev Digest, Vol 17, Issue 22

Send cip-dev mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific than "Re:
Contents of cip-dev digest..."

Today's Topics:

1. Re: Status of cip-core (Daniel Sangorrin)
2. B@D demos (Robert Marshall)


Message: 1
Date: Tue, 24 Oct 2017 14:17:17 +0900
From: "Daniel Sangorrin" <daniel.sangorrin@...>
To: "'Chris Paterson'" <Chris.Paterson2@...>,
Subject: Re: [cip-dev] Status of cip-core
Message-ID: <004001d34c87$5c8fcbe0$15af63a0$>
Content-Type: text/plain; charset="UTF-8"

Hello Chris,

-----Original Message-----
From: Chris Paterson [mailto:Chris.Paterson2@...]
Sent: Tuesday, October 24, 2017 3:23 AM
To: Daniel Sangorrin; cip-dev@...; 'Jan Kiszka'
Subject: RE: [cip-dev] Status of cip-core

Hello Daniel,

Thank you for the update.

- modules.tgz is not generated for iwg20m (for bbb it is): I have to
investigate why but I think it is not a big problem since they are
included in the file system images. Probably the reason is just that
shmobile_defconfig has modules disabled.
Correct :)
I have noticed that the shmobile_defconfig from the official linux-cip repo is
quite different from the one at

Previously I tested the official kernel using a ramdisk and it was successful so I
didn't notice the difference. But today I've tried to boot the official kernel
with the SD Card file system and it didn't work.

One problem was that EXT3/4 wasn't enabled. I decided to use renesas-cip's
shmobile_defconfig to build the official linux-cip kernel. However, I got a build
error because
references a firmware called "r8a779x_usb3_v1.dlmem" which wasn't
available on the official kernel. I could solve that either by copying the
firmware from renesas-cip or by commenting out the corresponding
configuration flags.

I managed to build the official kernel but still I couldn't get it to boot from the
SD Card.
# By the way, I noticed that the mmc numbering also changed (mmcblk0p2
was working on renesas-cip kernel as the 2nd partition of the SD Card, but for
the official kernel that was a partition on the eMMC and the kernel could not
recognize mmcblk2p2).

I wonder if this problem comes from the device tree. On the renesas-cip
repository there was a r8a7743-iwgm.dts file that worked fine, but on the
official repository the one with the closest name was r8a7743-iwg20d-q7.dts.
This one worked fine when I boot from a ramdisk but not when I boot from
the SD Card.
We are still working on upstream work on mainline and backport work on official cip-kernel.
So, I think the official repo not work now for Renesas board.

Should I use renesas-cip kernel again?
I noticed that the new versions are been merged. I was using renesas-cip's
v4.4.69-cip4 but I can see a newer branch called v4.4.83-cip8
The version 4.4.83-cip8 is not working now, we detected some issues and still working on it.
The older versions work OK, please use them.



Message: 2
Date: Tue, 24 Oct 2017 07:09:26 +0100
From: Robert Marshall <robert.marshall@...>
To: cip dev <cip-dev@...>
Subject: [cip-dev] B@D demos
Message-ID: <8760b55b6x.fsf@...>
Content-Type: text/plain


I shall be running Board at Desk demos with the beaglebone black board this
afternoon at the CIP stand at ELCE between 15:00 and 16:30.

Hope to see you there!



cip-dev mailing list

End of cip-dev Digest, Vol 17, Issue 22
Best regards,
Binh Nguyen

Join { to automatically receive all group messages.