Re: cip/linux-4.19.y-cip baseline-nfs: 12 runs, 1 regressions (v4.19.217-cip62) #kernelci


Chris Paterson
 

+kernelci ML as they will appreciate the feedback.

From: Pavel Machek <pavel@denx.de>
Sent: 30 November 2021 08:33

Hi!

So... I tried to understand this report, and still could not.

First problem is actually in the From: line. By placing bot there, it
is not clear who is responsible for this, and if someone reads replies
to the bot address.

I feel posts to mailing lists should be signed by human responsible
for them.

Then we have:

cip/linux-4.19.y-cip baseline-nfs: 12 runs, 1 regressions (v4.19.217-cip62)
Ok, so we may have an regression. That means it worked before and it
does not work now. I'd expect two versions "worked in v4.19.123-cip12,
now broken in v4.19.217-cip62", but we only have one.

Regressions Summary
-------------------

platform | arch | lab | compiler | defconfig | regressions
-----------------+-------+---------------+----------+-----------+------------
rk3399-gru-kevin | arm64 | lab-collabora | gcc-10 | defconfig | 1
Did you not have a "details" link here? In my copy of the email (attached) it links to
https://linux.kernelci.org/test/job/cip/branch/linux-4.19.y-cip/kernel/v4.19.217-cip62/plan/baseline-nfs/

If you click on the platform in question it says: "New regression, last pass: v4.19.216-cip61", which also links to the relevant build job.
I think it also says this in the email below the failed test case? (baseline-nfs.login)


URL: https://git.kernel.org/pub/scm/linux/kernel/git/cip/linux-cip.git
SHA: dc62e26e3be875a7324b85b8274c13a335e610dd
Still no note when it worked last.

HTML log: https://storage.kernelci.org//cip/linux-4.19.y-cip/v4.19.217-
cip62/arm64/defconfig/gcc-10/lab-collabora/baseline-nfs-rk3399-gru-
kevin.html
Again, there should also be a link to the specific failed test case, in this case:
https://linux.kernelci.org/test/plan/id/61a58c2989f6953bd118f6e4/

This includes a link to the defconfig used, although perhaps you'd like to know more about the platform.

Kind regards, Chris

Ok, so we have bootlog from a machine, that's quite unhappy. Part of
it are kernel problems, but we see missing firmware, too. In the end,
it looks like it has no usable network card, so it can not do NFS
boot... and panics.

It is hard to tell config problem vs. kernel bug without knowing more
about machine configuration. Best seeing previous successful runs...

Is there human here who believes this is a problem in -cip kernel that
is worth solving, and is willing to answer questions and test patches?

Best regards,

Pavel

02:27:34.443815 <4>[ 1.401574] cacheinfo: Unable to detect cache
hierarchy for CPU 0
02:27:34.452441 <6>[ 1.413496] loop: module loaded
02:27:34.464113 <4>[ 1.421343] rockchip-spi ff1d0000.spi: Failed
to request TX DMA channel
02:27:34.471531 <4>[ 1.429063] rockchip-spi ff1d0000.spi: Failed
to request RX DMA channel
02:27:34.487460 <6>[ 1.446867] m25p80 spi0.0: gd25lq64c (8192
Kbytes)
02:27:34.501792 <4>[ 1.459399] rockchip-spi ff1e0000.spi: Failed
to request TX DMA channel
...
02:27:48.313465 <6>[ 15.264576] atmel_mxt_ts 3-004b: Family: 164
Variant: 14 Firmware V2.3.AA Objects: 40
02:27:48.362782 <4>[ 15.318381] atmel_mxt_ts 3-004b: Direct
firmware load for maxtouch.cfg failed with error -2
02:27:48.535527 <4>[ 15.377455] atmel_mxt_ts 5-004a: Direct
firmware load for maxtouch.cfg failed with error -2
02:27:48.827088 ipconfig: no devices to configure
02:27:48.831012 ipconfig: no devices to configure
02:27:48.926132 <4>[ 15.866511] platform regulatory.0: Direct
firmware load for regulatory.db failed with error -2
02:27:48.931359 <6>[ 15.879008] pci 0000:00:00.0: PCI bridge to
[bus 01]
02:27:48.938653 <6>[ 15.879016] pci 0000:00:00.0: bridge window
[mem 0xfa000000-0xfa1fffff]

--
DENX Software Engineering GmbH, Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany

Join cip-dev@lists.cip-project.org to automatically receive all group messages.