Re: gitlab test failures -- job failed ... pods not found


Chris Paterson
 

Hello Pavel,

From: Pavel Machek <pavel@...>
Sent: 30 September 2022 11:51

Hi!

I have test failures all over the place:

-----------------
44Creating test job
45-----------------
46Version: Image_ctj_zynqmp_defconfig_5.10.145-cip17-rt7_411cd76b5
47Arch: arm64
48Config: ctj_zynqmp_defconfig
49Device: zynqmp-zcu102
50Kernel: Image
51DTB: zynqmp-zcu102-rev1.0.dtb
52Modules: N/A
53Test: smc
54------------------
55Uploading binaries
56------------------
58
Uploading artifacts for failed job
00:00
60
Cleaning up project directory and file based variables
00:00
62ERROR: Job failed (system failure): pods
"runner-bwzp7ahx-project-2678032-concurrent-0pstk2" not found

Initially everything failed, so I resubmitted everything, then three
succeeded but no more luck with resubmitting.
Thank you for reporting.
We recently upgraded the gitlab runner versions, but that was last week so it's a bit strange we're seeing issues now.
I've resubmitted a few of the jobs and as you say, some seem to work, others don't.

@Adler, Michael, could you take a look when you get a chance? Could this be caused by the recent upgrade?

Thanks, Chris



Example is
https://gitlab.com/cip-project/cip-kernel/linux-cip/-/jobs/3109431179,
I'm trying to test 5.10-rt release candidate
https://gitlab.com/cip-project/cip-kernel/linux-cip/-/pipelines/654967302
.

Any ideas?

Best regards,
Pavel
--
DENX Software Engineering GmbH, Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany

Join cip-dev@lists.cip-project.org to automatically receive all group messages.