Re: Plugin efibootguard-boot doesn't support to specify root parameter with unified kernel image


Quirin Gylstorff
 

Hi Cheng Shu Mou,

On 10/8/22 11:10, Mou, ChengShu(Ben) via lists.cip-project.org wrote:
Hi all,
I have a target image with following partitions:
|- bootloader (efibootguard)
|- system A (linux.efi)
|- system B (linux.efi)
|- root FS A
|- root FS B
My plan is to use plugin efibootguard-boot to generate linux.efi respectively for system A/B and they can mount related root FS. So, I need to specify root parameter respectively in linux.efi.
After checking the code, I found that there is only 1 place to specify it, bootloader command with option --append in wks file. This method can only specify 1 root parameter.
I have tried to modify this plugin as following:
Could please you sent your modification the next time as patch or text snippet?


Within this modification, linux.efi could contain its own root parameter.
I don’t know if it is a right way, please let me know if you have some suggestions. Thanks in advance.
With a fixed root parameter you need to ensure
that the partition you update is on all devices the same, e.g.
A -> B -> A
1.0 -> 1.1 -> 1.2

For example this does not work:
A -> A
1.0 -> 1.2

The customer needs to update first to 1.1 and B before updating to 1.2.

In cip we have solved this issue of root fs selection by adding a uuid or use verity checksum to identify the root file system corresponding to the linux.efi. This allows us to update independent from the root parameter.

Kind regards,

Quirin

Join cip-dev@lists.cip-project.org to automatically receive all group messages.