[isar-cip-core v2 1/3] cip-core-image-security: remove unnecessary dependency package names


Venkata Pyla
 

From: venkata pyla <venkata.pyla@...>

It is not necessary to mention the dependency package names in the recipe
because their names are changed when different distribution version
is used, and anyway the package manager will install the correct version
of dependencies when installing the main package, so it is safer to remove
the dependency packages here.

e.g:
For the Package: nftables
Dependecy package name in buster: libnftables0
Dependecy package name in bullseye: libnftables1

Signed-off-by: venkata pyla <venkata.pyla@...>
---
recipes-core/images/cip-core-image-security.bb | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/recipes-core/images/cip-core-image-security.bb b/recipes-core/images/cip-core-image-security.bb
index 61ddc39..c613dc9 100644
--- a/recipes-core/images/cip-core-image-security.bb
+++ b/recipes-core/images/cip-core-image-security.bb
@@ -17,20 +17,20 @@ IMAGE_INSTALL += "security-customizations"

# Debian packages that provide security features
IMAGE_PREINSTALL += " \
- openssl libssl1.1 \
+ openssl \
fail2ban \
openssh-server openssh-sftp-server openssh-client \
syslog-ng-core syslog-ng-mod-journal \
- aide aide-common \
- libnftables0 nftables \
+ aide \
+ nftables \
libpam-pkcs11 \
chrony \
tpm2-tools \
tpm2-abrmd \
- libtss2-esys0 libtss2-udev \
+ libtss2-esys0 \
libpam-cracklib \
acl \
- libauparse0 audispd-plugins auditd \
+ audispd-plugins auditd \
uuid-runtime \
sudo \
"
--
2.20.1