How to increase the size of the rootfs in the isar-cip-core image


Venkata Pyla
 

Hi,

 

For my experiment, I am trying to increase the rootfs size in isar-cip-core image, but I am unable to do.

 

I have tried the below variables but no luck:

 

+local_conf_header:

+    rootfs-image: |

+        IMAGE_ROOTFS_SIZE = "8392704"

+        IMAGE_OVERHEAD_FACTOR = "1.0"

 

and also below variable is not helpful.

+        IMAGE_ROOTFS_EXTRA_SPACE = "8392704"

 

Could anyone guide me how to do this.

 

Thanks for your help.

 

Venkata.


Kanagarajan, Vijaikumar
 

From: cip-dev@... <cip-dev@...> On Behalf Of Venkata Pyla
Sent: 23 June 2022 23:46
To: cip-dev@...
Subject: [cip-dev] How to increase the size of the rootfs in the isar-cip-core image

Hi,
 
For my experiment, I am trying to increase the rootfs size in isar-cip-core image, but I am unable to do.
 
I have tried the below variables but no luck:
 
+local_conf_header:
+    rootfs-image: |
+        IMAGE_ROOTFS_SIZE = "8392704"
+        IMAGE_OVERHEAD_FACTOR = "1.0"
 
and also below variable is not helpful.
+        IMAGE_ROOTFS_EXTRA_SPACE = "8392704"
 
Could anyone guide me how to do this.

Hi Venkata,

Can you try setting ROOTFS_EXTRA? Units are in MB.

https://github.com/ilbers/isar/blob/1000df8e98b9a5849a7897698039687fd0cdd7d3/meta/classes/image.bbclass#L88

Thanks,
Vijai Kumar K


Thanks for your help.
 
Venkata.


Venkata Pyla
 

Thanks Vijaikumar,

I am able to increase the rootfs size by using the variable 'ROOTFS_EXTRA'.

-----Original Message-----
From: cip-dev@... <cip-dev@...> On Behalf Of
Kanagarajan, Vijaikumar
Sent: 24 June 2022 10:44
To: cip-dev@...
Subject: Re: [cip-dev] How to increase the size of the rootfs in the isar-cip-core
image



From: cip-dev@... <cip-dev@...> On Behalf Of
Venkata Pyla
Sent: 23 June 2022 23:46
To: cip-dev@...
Subject: [cip-dev] How to increase the size of the rootfs in the isar-cip-core
image

Hi,

For my experiment, I am trying to increase the rootfs size in isar-cip-core image,
but I am unable to do.

I have tried the below variables but no luck:

+local_conf_header:
+    rootfs-image: |
+        IMAGE_ROOTFS_SIZE = "8392704"
+        IMAGE_OVERHEAD_FACTOR = "1.0"

and also below variable is not helpful.
+        IMAGE_ROOTFS_EXTRA_SPACE = "8392704"

Could anyone guide me how to do this.

Hi Venkata,

Can you try setting ROOTFS_EXTRA? Units are in MB.

https://github.com/ilbers/isar/blob/1000df8e98b9a5849a7897698039687fd0cdd
7d3/meta/classes/image.bbclass#L88

Thanks,
Vijai Kumar K


Thanks for your help.

Venkata.